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WHAT IS “BREKEL BODY” 

 

 

 

“Brekel Body” is a Windows application that enables 3D animators to record body Motion Capture data in their 

living room or office using a Microsoft Kinect sensor. 

Internally tracking is done using the Microsoft Kinect SDK. 

 

It is written by Jasper Brekelmans, so in case you’re wondering that’s what “Brekel” refers to. 

“Brekel” is pronounced as “Break–uhl”. 

  



REQUIREMENTS 

 - Kinect for Windows or Kinect for XBox sensor 

- Power supply for the Kinect sensor 

 - Microsoft Windows 7 or higher 

 - Core i5 or i7 CPU 

 - Dedicated USB 2.0 (or 3.0) bus 

 - 4 GB RAM or more 

 - Graphics card with OpenGL support 

 

A Kinect for Windows sensor will also support ‘near mode’ allowing capture as close to 40 cm from the sensor, 

the minimum distance for a Kinect for Xbox sensor is 80 cm. 

 

The Kinect for Windows sensor also supports control of the color camera settings like auto exposure, 

whitebalance etc. 

 

Note: when you bought your Kinect for Xbox separately you should have a separate power supply. 

If you’ve bought it bundled with an Xbox360 game console you need to buy a separate power supply, USB only 

will not be enough. 

  



 

INSTALLATION 

 

In order for “Brekel Kinect Pro Body” to work you will need to have the Microsoft drivers installed for your 

Kinect sensor. If you’ve got a different set of Kinect drivers installed (OpenNI, OpenKinect or CLNui for 

example) please first uninstall them. 

(Note that the free “Brekel Kinect” application uses the OpenNI drivers) 

 

The installer should have taken care of installing the drivers already but in case you want more details: 

 

Please consult the following page for driver download and installation help: 

http://www.microsoft.com/en-us/kinectforwindows/develop/developer-downloads.aspx 

 

Kinect for Xbox sensors will ONLY work with the full SDK 

 

 

Kinect for Windows sensors will work with the full SDK as well as the runtime (which is smaller to download) 

 

 

 

The “Brekel Kinect Pro Body” installer will try to automatically detect any installed MotionBuilder versions (in 

the default locations) and install the appropriate plugins for streaming. 

You can also manually copy the MotionBuilder plugins from the installed folder.  

http://www.microsoft.com/en-us/kinectforwindows/develop/developer-downloads.aspx


LICENSING 

 

With your purchase you should have received a download link for the retail version of the software and an 

email with your license code. (Please allow up to 24 hours for processing your request and double check your 

spam filter) 

 

The retail version will work immediately and with no restrictions even without a valid license, but will need 

activation within 5 days for continuous operation. 

 

You can activate your copy by using the “File > Install License” option from the menu. 

 

 

It will ask you to browse for your license file (which was attached to the mail). 

The license will automatically be copied to your “C:\ProgramData” folder and be active upon restart of the 

application. 

 

To display the current license info use the “File > Show License Info” option from the menu to display a 

window like the following: 

 

  



THE MAIN INTERFACE 

 

 

The interface is divided in 5 main groups. 

- Settings 

- 3D View 

- Record 

- Video 

- Depth 

- System Info 

These groups can be undocked and turned into a floating window by dragging them from their title bar. 

Double clicking on the taskbar of a floating window will dock it back into the main window. 

The state will automatically be saved on exit and reloaded on start. 

  



SETTINGS 

 

 

Calibrate Sensor Position/Rotation 

Using this button you can calibrate the software so the pointcloud and tracking is adjusted for a sensor that is 

tilted up or down and adjust for the height of the sensor from the ground. 

 

First set the desired tilt using the slider on the right of the 3D view, make sure you are fully in view. 

During calibration the tilt motor will be adjusted so the sensor is horizontal. 

The lowest visible point will then be measured and be used to estimate the sensor’s height from the ground. 

The tilt motor will then be adjusted back to the previously set angle. 

Angle estimation is done using the sensor’s internal accelerometer. 



Sensor Position 

Adjusting these XYZ values will translate the pointcloud and resulting skeleton, the main value of interest is the 

Y value depicting the height of the sensor above the ground. 

These values will be filled out by the automatic calibration, but can also be changed manually. 

 

Sensor Rotation 

Adjusting these XYZ values will rotate the poitncloud and resulting skeleton, which can be of use when the 

sensor is tilted. 

These values will be filled out by the automatic calibration, but can also be changed manually. 

 

Reset Sensor Calibration 

Resets the Sensor Position and Rotation values back to 0 

 

Skeleton Mode 

“Full Body” mode will detect and track persons from head to toe using 20 joints. 

Users are detected and segmented from the environment based on their distance from the background. 

 

“Upper Body Only” mode will only track the torso, arms and head using ten joints, this is best used for when 

the feet are not visible to the sensor. 

Users are detected and segmented from the environment based on movement. 

 

Initialize Lower Body 

Will snap the lower body to the correct position when in “Upper Body Only” tracking mode. 

 

Number of persons 

Selects either One or Two person tracking. 

 

Picking Mode 

“Sticky” will try to keep tracking people continuously without swapping. 

“Closest to Sensor” will try to pick the people that are closest to the sensor for tracking. 



Occlusion Solver 

Choose algorithm that tries to solve joints that are hidden for the sensor. 

“Brekel” tends to generate slightly better results than the standard “Microsoft Kinect SDK” one. 

 

Grip Detection 

Detect open/closed hands and create finger skeletons, note that this ONLY works if the hands are in front of 

the body. 

 

Grip Damping 

Smoothly blend between open and closed hand 

 

Filtering 

Since the sensor data and markerless tracking inherently contains noise this enables specially designed filters 

to reduce the noise but retain the data as well as possible. Note that this will always introduce some additional 

lag. 

 

  



Old Algorithm 

You can use the Light/Medium/Heavy presets or tune the parameters further yourself. 

 

Smoothing 

Increasing the smoothing parameter value leads to more highly-smoothed skeleton position values being 

returned. 

It is the nature of smoothing that, as the smoothing value is increased, responsiveness to the raw data 

decreases. 

Thus, increased smoothing leads to increased latency in the returned skeleton values. 

 

Correction 

Lower values are slower to correct towards the raw data, and appear smoother, while higher values will 

correct toward the raw data more quickly. 

 

Prediction 

The number of frames to predict into the future. 

 

Values greater than 0.5 will likely lead to overshooting when moving quickly. 

This effect can be damped by using small values of MaxDeviationRadius. 

 

Jitter Radius 

The radius in meters for jitter reduction. 

Any jitter beyond this radius is clamped to the radius. 

 

Max Deviation Radius 

The maximum radius in meters that filtered positions are allowed to deviate from raw data. 

Filtered values that would be more than this radius from the raw data are clamped at this distance, in the 

direction of the filtered value. 

  



New Algorithm 

Generally provides results that are closer to the original data, with better smoothing characteristics and less 

lag. 

 

Tuning is best done by first lowering the Minimum Cutoff until the desired amount of smoothing is reached. 

Then raising the Cutoff Slope to reduce the lag just until it gets noisy again. 

Good default values are 1.0 for both. 

 

Minimum Cutoff 

Lower numbers for more smoothing. 

 

Cutoff Slope 

Higher numbers to reduce lag. 

 

Extra hand filter 

Extra filter pass for hands rotations. 

Extra foot filter 

Extra filter pass for foot rotations. 

  



THE 3D VIEW 

 

 

 

The main area displays the 3D pointcloud data and tracked skeletons. 

For navigation: 

- Left mouse button for orbit 

- Middle mouse button for dolly 

- Right mouse button for drag 

- Mouse wheel for dolly 

 

Below the 3D view the audio (coming from the built in microphones) is displayed as a waveform. 

  



FPS 

The speed (in frames per second) the tracker is running at, note that this can be higher than the video/depth 

input streams since filtering/smoothing can be applied to the data on inbetween frames. 

 

Draw Floor 

Toggles showing the floor grid in the 3D view. 

 

Point Cloud 

Toggles drawing of the 3D pointcloud, not that disabling this can speed up the application on slow machines. 

 

Clip Persons 

This will remove points in the pointcloud that do not belong to any of the identified persons . 

 

Skeleton 

Toggles display of the tracking skeletons in the 3D view. 

 

Joint Axis 

Shows the axis for each of the joints of the tracked skeletons. 

 

Clipped Top/Bottom/Left/Right 

These indicators light up when the skeleton is clipped by the edge of the (depth) sensor. 

For best tracking results keep the bodyparts within view. 

 

Tilt Angle slider 

Use this to adjust the sensor’s tilt motor to point the viewing direction up or down. 

After making adjustments it’s best to hit the Calibrate Sensor Position/Rotation button again so the pointcloud 

and skeletons can be adjusted automatically.  



RECORD 

3D Tab 

  

T-Pose on first frame 

Creates an artificial T-Pose on the first frame when exporting. 

Note that it’s usually better to capture a T-Pose from your actor as this will include any offsets that the tracker 

produces and will usually retarget more accurately. 

 

FBX file format 

FBX files should be readable by most 3D packages it contains the most accurate representation of the tracked 

skeletons. 

V7.3 is the latest version, v6.1 should be compatible with older 3D packages. 

If two person tracking is enabled, a single FBX file will contain both skeletons in separate hierarchies. 



BVH 

BVH are a common skeleton format for which a lot of 3D packages have importer plugins/scripts. 

If two person tracking is enabled, two BVH files will be saved, each containing a single skeleton. 

Note that BVH is a legacy format which is not implemented correctly in some 3D packages, it is strongly 

recommended to use an FBX workflow for best results. 

 

BVH naming convention 

Specifies which bone-name template is used, note that each type has the exact same hierarchy but with 

different names for the bones to comply with different software packages. The following templates are 

available: 

- Generic (same as Autodesk HumanIK / MotionBuilder standard naming convention) 

- 3DMax Biped 

- Second Life 

- Poser / DAZ 

 

Write Positions 

The markerless tracking algorithm tracks joint positions and therefore can produce bones that slightly vary in 

length during tracking. 

To retain this information in the BVH files bones can be saved with both rotational and positional information. 

Note that if this function is turned off, or if your importer can’t deal with positions, the skeletons may appear 

to float a bit more. 

 

TXT 

Toggles if the skeleton tracking data should be exported to disk as a text file. 

A Maya mel script is included in the installation folder that shows how to parse these text files. 

If two person tracking is enabled, two TXT files will be saved, each containing a single skeleton. 

 

CSV 

Writes to a Comma Separated Values file containing angles for the joints. 

This could for example be used to analyze the data in a spreadsheet. 

If two person tracking is enabled, two CSV files will be saved, each containing a single skeleton. 

  



Audio Tab 

 

 

Available Devices 

List the available audio devices that can be used for recording and allows you to select one of them. 

 

Number of Channels 

Switches between Mono and Stereo recording. 

 

Sampling Rate 

Sample rate to record (in Hz). 

 

Sample Size 

Amount of bits (8 or 16) used for recording. 

 

Note that audio is always recorder in the WAV format. 



Video Tab 

 

 

AVI 

Toggles if the video data should be exported to disk in the AVI movie format. 

 

Ask for codec 

When turned ON the program will ask which codec to use for the AVI file. (Available codecs will depend on 

what is installed on your system) 

When turned OFF the XVID codec will automatically be used. Since it has a nice tradeoff of quality, filesize and 

speed. 

If you’re having trouble with codecs I can recommend the K-Lite codec pack and/or Xvid: 

http://www.codecguide.com/download_kl.htm 

http://www.xvid.org/ 

Remember to also install the x64 version of the codec if you’re using the x64 version of Brekel Kinect Pro Body. 

http://www.codecguide.com/download_kl.htm
http://www.xvid.org/


 

Direct to Disk 

When turned ON, video frames will be compressed and saved to disk during the recording. Depending on your 

CPU speed, selected codec and disk speed this uses the least amount of memory but has a chance of dropping 

frames on slow machines. 

When turned OFF, video frames will be recorded in memory first and compressed to disk after the recording is 

stopped. If your system has enough memory this is the fastest method and has the lowest risk of frames being 

dropped. 

 

Overlay Filename 

Prints the filename into the video 

 

Overlay Frame Number 

Prints the frame number into the video 

 

  



Network Tab 

 

Protocol 

Selects either TCP/IP or UDP as the streaming protocol, or turns streaming off. 

 

Port 

The network port from which data will be streamed out of. (default 8875) 

 

State 

The current state of the network streaming. 

 

Please make sure security software (firewall) is not blocking network streaming! 

  



Bottom part of Record window 

 

Output Folder 

The folder where the recorded output files will be placed. 

 

Output Filename 

The filename of the recorded files. (disabled when Auto Filename is turned on) 

 

Auto Filename 

When turned on a filename will automatically be created using the current date/time. 

 

Open Folder 

Opens the output folder in Windows Explorer. 

 

Browse 

Opens a file browser so you can specify the output folder. 

 

Start Delay 

When bigger than 0 a countdown will start after starting a recording, giving you a few seconds to get into 

position before capture will start. 

During countdown there will be beeps played over the speakers every second, and the amount of remaining 

seconds will also be shown visually in the 3D window. 

 

Recorded 

Displays the amount of frames and seconds recorded in the last take. 

 

Start/Stop Recording 

Toggle button for starting & stopping the recording. (Note the button turns red while recording) 

 

  



VIDEO 

 

Shows the incoming video stream from the Kinect sensor. 

 

FPS 

The speed (in frames per second) of the incoming video stream, this should be roughly the same as depicted in 

the chosen “Video Resolution”. If it is drastically lower your system may be too slow. 

 

Draw 

Turns drawing in the GUI ON/OFF, this may save a few CPU cycles on slow machines. 

 

Video Resolution 

The Kinect can work at 640x480 at 30fps, or at 1280x960 12fps. 

Note that the application needs to restart for the new resolution to take effect. 

  



Camera Settings (only available on Kinect for Windows devices) 

Opens a floating window that allows control over Exposure and Color settings, useful when working in low light 

situations or when you want manual control instead of automatically adjusting settings. 

 

  



DEPTH 

 

Shows the incoming depth stream from the Kinect sensor. 

 

FPS 

The speed (in frames per second) of the incoming depth stream, this should be roughly the same as depicted in 

the chosen “Depth Resolution”. If it is drastically lower your system may be too slow. 

 

Draw 

Turns drawing in the GUI ON/OFF, this may save a few CPU cycles on slow machines. 

 

Depth Resolution 

The Kinect can work at 640x480 or at 320x240, both are at 30fps. 

Note that the application needs to restart for the new resolution to take effect. 



Point Size 

Visually adjusts the size of the tracking points 

 

Near Mode (only available on Kinect for Windows devices) 

When turned ON the Kinect will senses depths roughly between 40cm and 3 meters from the sensor. 

When turned OFF the Kinect will senses depths roughly between 80cm and 4 meters from the sensor. 

 

Note that when a person is detected the Depth view will reflect this by drawing the pixels belonging to that 

user in a different color.  

 

In Full Body mode user detection needs some distance between the person(s) and the background. 

In Upper Body Only mode user detection will usually need a few frames of movement. 

 

When persons are detected and tracked their joints and skeleton are drawn as an overlay. 

Joints in green are visible to the sensor and can be tracked. 

Joints in orange are not fully visible and are inferred from existing data and therefore can be less accurate. 

  



TOP MENU 

File > Install License 

Let’s you browse to a license file and installs it to be used for the next time the application is run. 

 

File > Show License Info 

Shows if a license is installed and who it belongs to. 

 

File > Exit 

Saves settings and exits the application (same as clicking the X in the top right corner) 

 

  



Settings > Check for new version on start 

Will check online if a new version is available and lets the user know if there is one. 

 

Settings > Use Multi Threading 

When turned ON does more processing in parallel for multi-core/multi-cpu machines. 

Note that depending on your machine’s configuration, and especially the amount of available cores and their 

speed, this may be faster or slower. 

 

Settings > Tweak Sleep Time (advanced users) 

Internally processing is done on multiple threads, when no new data is available these threads go to sleep for a 

few milliseconds until they request new data. 

Advanced users may want to tweak this setting to gain a few FPS on slower machines, or gain responsiveness 

on faster machines that still have CPU time to spare. 

Note that bumping this too high will force evaluation to run at speeds lower than 30 FPS and therefore drop 

frames. 

 

  



Window > Dark Skin 

Toggles between the regular style (light) GUI and the dark style. 

 

Window > Record 

Toggles visibility of the “Record” dock. 

 

Window > Settings 

Toggles visibility of the “Settings” dock. 

 

Window > Video 

Toggles visibility of the “Video” dock. 

 

Window > Depth 

Toggles visibility of the “Depth” dock. 

 

Window > System Info 

Toggles visibility of the “System Info” dock. 

 

  



Help > Open Help File (PDF) 

Opens this help file, which can also be found in the installation folder. 

 

Help > Open Downloads Page 

Opens the standard web browser and directs it to the webpage with the latest installer downloads. 

 

Help > Open Forums 

Opens the standard web browser and directs it to the user forums. 

  



SENSOR PLACEMENT 

 

 

 

In default mode the Kinect sensor can see people standing between 0.8 meters (2.6 feet) and 4.0 meters (13.1 

feet) away. 

A practical range is between 1.2 and 3.5 meters to allow for enough room for the user to move their arms. 

 

In near mode the maximum range is between 0.4 meters (1.3 feet) and 3.0 meters (9.8 feet), with a practical 

range of 0.8 to 2.5 meters. 

 

Sensor height is ideally at about hip height, but the software will try to correct for sensor placement ranging 

from ground level to above-head level. 

 

Note that the sensor can not be mounted sideways or upside down since users can not be tracked in those 

orientations. 

 

Tracking will always assume the person is facing the sensor.  



MOTIONBUILDER PLUGIN INSTALLATION 

The installer should have automatically installed the plugins for the available versions of MotionBuilder. 

And you should now have a “Brekel Kinect Pro Body Device” listed under the “Devices” folder of the “Asset 

Browser”. 

 

 

If it doesn’t show up, you can find all the plugins for the various MotionBuilder versions (2009-2014 both 32- 

and 64 bit) in the “Brekel Kinect Pro Body” installation folder, usually in: 

C:\Program Files\Brekel Kinect Pro Body \MotionBuilder plugins 

 

Simply copy the .dll file of your particular MotionBuilder version to it’s plugin folder. 

Typically for a 32 bit version: 

C:\Program Files (x86)\Autodesk\MotionBuilder 2013\bin\win32\plugins 

 

For a 64 bit version: 

 C:\Program Files\Autodesk\MotionBuilder 2013\bin\x64\plugins 

  



USING THE MOTIONBUILDER PLUGIN 

First make sure “Brekel Kinect Pro Body” is running. 

 

 

To setup a MotionBuilder scene go through the following steps: 

- drag a “Brekel Kinect Pro Body Device” from the “Devices” folder in the “Asset Browser” into your 

scene. 

- In the GUI for the device make sure the “Hostname/IP” points to the machine running the          

“Brekel Kinect Pro Body” application. This can either be a separate machine that is reachable over a 

network connection or the same machine. 

- (Note: if both applications are running on the same machine you can simply use the default 

Hostname/IP of “127.0.0.1”) 

- Toggle the “Online” button to turn the device on 

- Under “Model binding:” hit the “None” option and then “Create”, this will create a model hierarchy in 

your scene containing the skeletons 

 

 

 

 

 



Hostname/IP 

Should point to the machine running Brekel Kinect Pro Body. 

If both MotionBuilder and Pro Body run on the same machine you can also leave this at the default of localhost 

or 127.0.0.1 

 

Port 

Should be the same port as used in the Brekel Kinect Pro Body application. (default 8875) 

 

Protocol 

Should be the same protocol (TCP/IP or UDP) as used in the Brekel Kinect Pro Body application. 

 

T pose delay 

When bigger than 0 a countdown will start after hitting the (Re)Create Character Nodes button, giving you a 

few seconds to get into position in a T-pose. 

Note that on MotionBuilder 2012 and higher a visual indicator should also appear in the 3D viewport indicating 

the amount of seconds left. 

 

(Re)Create Character Nodes 

Creates (or recreates if they already exists) Character nodes for the Kinect skeletons, allowing for quick 

retargeting setups to other characters. 

Note that the actors should be in a T-pose for this to work correctly, since MotionBuilder uses that poses to 

map from one character to another. 

 

Reset T Poses 

Resets existing Character nodes without recreating them. (Note that the actors should be in a T-pose) 

 

Use Foot Rotation 

Depending on your character the MotionBuilder’s retargeting can have some problems with the noise on the 

feet coming from the Kinect’s tracker. So it can be a good idea to keep these disabled and rely on floor 

contacts. 

  



To record a sequence: 

- Make sure “Online” on the device is toggled ON 

- Make sure “Live” on the device is toggled ON 

- Make sure “Recording” on the device is toggled ON 

- Make sure the “Record” button on the timeline transport controls is toggled ON 

- Hit the Play button, and Stop button once the action is over 

 

To play back a recording: 

- Make sure “Online” on the device is toggled ON 

- Make sure “Live” on the device is toggled OFF 

- Hit Play on the timeline transport controls or scrub trough the timeline 

 

To setup a Character Node 

- MotionBuilder can retarget motion from one skeleton to another as long as Character Nodes are 

created. The device can automatically create one for the Kinect skeletons 

- Make sure the actor(s) assume a T-pose 

- Note that when you are both the operator and actor you can simply record a clip and scrub through 

the T-pose frame 

- Hit the “(Re)Create Character Nodes” button and note that “Brekel Kinect” Characters will be placed 

in the scene 

- Note that you can always recreate the nodes, or hit the “Reset T Poses” button in case the T-pose was 

not accurate enough. 

- You can now go to the Character Node of the character you want to drive with the Kinect data and set 

o Input Type to “Character” 

o Input Source to one of the Kinect character nodes 

o Active to ON 

- Your character should now be driven by the live or recorded Kinect data 

  



LIVE STREAMING INTO UNITY 

You can find the Unity example script/scene for streaming live network data in the “Unity3D” folder inside 

the Brekel installation folder, usually something like here: 

C:\Program Files\Brekel Kinect Pro Body x64\Unity3D 

 

You can also find the latest ReadMe.txt file here with instructions  

 

  



LIVE STREAMING INTO UNREAL ENGINE 4  

 

Live data can be streamed into the Unreal Engine 4 engine using its Live Link feature. 

 

In the Brekel app make sure "Unreal Engine 4 Live Link" is enabled on the "Network" panel 

 

 

First make sure you enable this feature in the UE4 engine: 

• Click Edit > Plugins 

• Enable "Live Link" under "Animation" 

 

 

 

 

 



Click Window > Live Link 

 

 

In Live Link Window 

• click Add > Message Bus Source 

• "Brekel Body v2" should be listed under Source Type/Machine, click it and hit Ok 

 

 

  



• Any visible and tracked bodies should be listed under "Subject Name" 

• Take note of the body name you want to use 

• "Closest_Body" for the body that is closest to the sensor 

•  "Body_0" - "Body_5" for a specific body, note that the body IDs can be displayed in the Brekel 3D 

viewport for reference 

 

 

  



In the Content Browser: 

• Import "base_skeleton.fbx" 

• You can find this file in the “UnrealEngine4” folder inside the Brekel installation folder, usually 

something like here: 

• C:\Program Files\Brekel Kinect Pro Body x64\UnrealEngine4 

 

• Add New - Animation BluePrint 

 

 

• Pick “brekel_example_Skeleton” from the list 

 



 

• Open the newly created blueprint by double clicking on it 

• Right click in empty blueprint area 

• Create a new "Live Link Pose" node 

 

  



• Change Subject Name - None into the body you want to use ("Closest_Body" most probably) 

 

 

• Connect Live Link Pose node to Final Animation Pose node 

 

 

• Hit save and compile 

o You should now see a live data connection between the nodes 

o You should now see live data in the 3D window 

 



STREAMING PROTOCOL 

 

“Brekel Kinect Pro Body” has a TCP server running on port 8875. 
 
Once a connection is established for each frame the following struct is passed twice in a row. 
Once for the fist tracked person, then for the second person, even when single person tracking is selected. In 
that case the second person’s struct can be considered empty. 
 
struct   
{ 
 int isTracked; 
 int seatedSkeleton; 
 int clipped_left; 
 int clipped_right; 
 int clipped_top; 
 int clipped_bottom; 

double timeStamp; 
float grip_left; 

 float grip_right; 
 

 
 float conf_waist;  float pos_waist[3];  float rot_waist[3]; 
 float conf_spine;  float pos_spine[3];  float rot_spine[3]; 
 float conf_neck;  float pos_neck[3];  float rot_neck[3]; 
 float conf_head;  float pos_head[3];  float rot_head[3]; 
 float conf_upperLeg_L;  float pos_upperLeg_L[3]; float rot_upperLeg_L[3]; 
 float conf_lowerLeg_L;  float pos_lowerLeg_L[3]; float rot_lowerLeg_L[3]; 
 float conf_foot_L;  float pos_foot_L[3];  float rot_foot_L[3]; 
 float conf_toes_L;  float pos_toes_L[3];  float rot_toes_L[3]; 
 float conf_upperLeg_R;  float pos_upperLeg_R[3]; float rot_upperLeg_R[3]; 
 float conf_lowerLeg_R;  float pos_lowerLeg_R[3]; float rot_lowerLeg_R[3]; 
 float conf_foot_R;  float pos_foot_R[3];  float rot_foot_R[3]; 
 float conf_toes_R;  float pos_toes_R[3];  float rot_toes_R[3]; 
 float conf_collar_L;  float pos_collar_L[3];  float rot_collar_L[3]; 
 float conf_upperArm_L;  float pos_upperArm_L[3]; float rot_upperArm_L[3]; 
 float conf_foreArm_L;  float pos_foreArm_L[3]; float rot_foreArm_L[3]; 
 float conf_hand_L;  float pos_hand_L[3];  float rot_hand_L[3]; 
 float conf_fingers_L;  float pos_fingers_L[3]; float rot_fingers_L[3]; 
 float conf_collar_R;  float pos_collar_R[3];  float rot_collar_R[3]; 
 float conf_upperArm_R;  float pos_upperArm_R[3]; float rot_upperArm_R[3]; 
 float conf_foreArm_R;  float pos_foreArm_R[3]; float rot_foreArm_R[3]; 
 float conf_hand_R;  float pos_hand_R[3];  float rot_hand_R[3]; 
 float conf_fingers_R;  float pos_fingers_R[3]; float rot_fingers_R[3]; 
 
 float conf_thumb_L[4];  float pos_thumb_L[3][4]; float rot_thumb_L[3][4]; 
 float conf_index_L[4];  float pos_index_L[3][4]; float rot_index_L[3][4]; 
 float conf_middle_L[4]; float pos_middle_L[3][4]; float rot_middle_L[3][4]; 
 float conf_ring_L[4];  float pos_ring_L[3][4]; float rot_ring_L[3][4]; 
 float conf_pinky_L[4];  float pos_pinky_L[3][4]; float rot_pinky_L[3][4]; 
 float conf_thumb_R[4];  float pos_thumb_R[3][4]; float rot_thumb_R[3][4]; 
 float conf_index_R[4];  float pos_index_R[3][4]; float rot_index_R[3][4]; 
 float conf_middle_R[4]; float pos_middle_R[3][4]; float rot_middle_R[3][4]; 
 float conf_ring_R[4];  float pos_ring_R[3][4]; float rot_ring_R[3][4]; 
 float conf_pinky_R[4];  float pos_pinky_R[3][4]; float rot_pinky_R[3][4]; 
};  

 

After the body structs the following data is sent: 

int mNumPeopleSeen; 
float bodyPositions[3][6]; 

 

  



The int values are either 0 or 1 depicting an on/off state 

The timestamp is in seconds 

The grips vary between 0.0 (open hand) and 1.0 (closed hand) 

The confidences can be 

0.0 for non-tracked joints 

0.5 for inferred joints (hidden from the sensor but estimated using other joints) 

1.0 for tracked joints 

Each finger comes in an array of 4 elements depicting 3 knuckles and the tip. 

Fingers only contain valid data if “Grip Detection” is turned ON in the base application. 

The positions are in XYZ order and in local space 

The rotations are euler angles in degrees in XYZ order and in local space 

 

Parenting is like this: 

 

Joint  parent 

waist  root 

spine  waist 

neck  spine 

head  neck 

upperleg waist 

lowerleg  upperleg 

foot  lowerleg 

toes  foot 

collar  spine 

upperarm collar 

forearm  upperarm 

hand  forearm 

fingers  hand 

 



Every data packet starts with 3 bytes describing the start of a packet and buffersize, you can ignore these and 

can start parsing all of the above information starting at the 4th byte in the packet you receive. Or use them for 

validity checking. 

 

The bodyPositions are 3D positions vectors for a total of up to 6 people. 

When fewer than 6 people are in front of the sensor the positions are 0,0,0 

Note that people are assigned a semi-random slot of the available 6. (note that only 2 people can be fully 

tracked at a time) 

  



 

RUNNING IN COMMANDLINE MODE 

 

For advanced users who are only interested in using the network streaming it is possible to run Brekel Kinect 

Pro Face in command line mode so it uses as few CPU power as possible. 

 

Simply add the “-commandline” argument when starting the application and it will run without the GUI and 

still stream out the data over the TCP/UDP network socket. 

 

Note that settings will be loaded from the registry as usual, so you can use the GUI to set things like tilt angle, 

near mode, smoothing settings etc. 

 

 

  



COMMANDLINE OPTIONS 

 

Advanced users can use one or more of the following commandline options: 

 

-sensorId 0 

In case you have multiple sensors connected to one machine you can specify which 

one to use by changing the value of 0 to a higher number. (note that this 

currently cannot be set from the GUI) 

 

-noVBO 

Adding this will force the rendering to not use any Vertex Buffer Object 

optimizations, which may cause problems on certain graphics cards and/or drivers. 

(note that this currently cannot be set from the GUI) 

 

-commandline 

Runs without a GUI, enabling only the network streaming, but still loads the 

settings that were used by the GUI version. 

See next chapter for more info. 

 

-elevationAngle 0 

Sets the device’s tilt angle to the chosen value, valid range is from -27 to +27 

 

-videoResolution 0 

0 sets video resolution to 640 x 480 (30 fps) 

1 sets video resolution to 1280 x 960 (12fps) 

 

-depthResolution 0 

0 sets depth resolution to 320 x 240 (30 fps) 

1 sets video resolution to 640 x 480 (30 fps) 

 

 



 

-nearMode 0 

0 turns nearMode OFF 

1 turns nearMode ON (Kinect for Windows devices only) 

 

-sleeptime 10 

Sets how many milliseconds the internal threads will wait before they check for 

fresh data. 

 

-multiThreading 

Forces multi threading to be used wherever possible. 

 

-networkNone 

turns network streaming OFF 

 

-networkTCP 

sets network streaming protocol to TCP 

 

-networkUDP 

sets network streaming protocol to UDP 

 

-networkPort 8875 

Sets the network streaming to the chosen port. 

 

-skeletonMode 0 

0 for Full Body tracking mode 

1 for Upper Body Only tracking mode 

  



-numPersons 1 

1 for single person tracking 

2 for two person tracking 

 

-filtering 0 

0 turns filtering OFF 

1 turns filtering ON 

 

-useOldFiltering 

Uses Old Algorithm for filtering the data 

 

-useNewFiltering 

Uses New Algorithm for filtering the data 

 

-smoothing 0.5 

Sets the amount of filter smoothing, valid range is from 0.0 to 1.0 (for Old 

Algorithm) 

 

-corection 0.5 

Sets the amount of filter correction, valid range is from 0.0 to 1.0 (for Old 

Algorithm) 

 

-prediction 0.5 

Sets the amount of filter prediction, valid range is from 0.0 to 2.0 (for Old 

Algorithm) 

 

-jitterRadius 0.05 

Sets the jitter radius for the filtering, valid range is from 0.0 to 1.0 (for Old 

Algorithm) 

  



-maxDeviationRadius 0.04 

Sets the max deviation radius for the filtering, valid range is from 0.0 to 1.0 

(for Old Algorithm) 

 

-filterPreset 0 

0 sets the filtering settings to the Light preset 

1 sets the filtering settings to the Medium preset 

2 sets the filtering settings to the Heavy preset 

(for Old Algorithm) 

 

-minimumCutoff 

Sets Minimum Cutoff, valid range is 0.0 and higher (for New Algorithm) 

 

-cutoffSlope 

Sets Cutoff Slope, valid range is 0.0 and higher (for New Algorithm) 

 

-extraFilterHands 

Turns on additional filter pass for hand rotations (for New Algorithm) 

 

-extraFilterFeet 

Turns on additional filter pass for foot rotations (for New Algorithm) 

 

-gripDetection 0 

0 turns Grip Detection OFF 

1 turns Grip Detection ON 

 

-gripDamping 0.5 

Sets the amount of filtering on the grip detection hands open/closed pose, valid 

range is from 0.0 to 1.0 

 

  



-OSC_enable 0 

 0 disable OSC data streaming 

 1 enable OSC data streaming 

 

-OSC_host localhost 

 Sets the hostname/IP of the machine to which to stream OSC data 

 

-OSC_port 7775 

 Sets the port over which to stream OSC data 

 

-OSC_mode 0 

Sets the formatting of the OSC data 

  0 Brekel 

1 Synapse 

2 OSCeleton 

3 OSCeleton Kitchen 

4 OSCeleton Quartz Composer 

 


